分享用E语言写的工资条群发软件

Published on 2014 - 08 - 26

分享一个自己用E语言写的工资条群发软件~ 收到人事部好评,并且收到了奖金,嘿嘿,下面是运行图片跟代码

--------------------------------------------程序代码-----------------------------------------------------------
.版本 2
.支持库 eGrid

.程序集 窗口程序集1
.程序集变量 i, 短整数型
.程序集变量 _空格, 文本型
.程序集变量 _月份, 文本型, , "300"
.程序集变量 _员工姓名, 文本型, , "300"
.程序集变量 _工作天数, 文本型, , "300"
.程序集变量 _月基本薪金, 文本型, , "300"
.程序集变量 _备注, 文本型, , "300"
.程序集变量 _午餐补贴, 文本型, , "300"
.程序集变量 _全勤奖, 文本型, , "300"
.程序集变量 _其它补贴, 文本型, , "300"
.程序集变量 _奖金项目1, 文本型, , "300"
.程序集变量 _奖金1, 文本型, , "300"
.程序集变量 _奖金项目2, 文本型, , "300"
.程序集变量 _奖金2, 文本型, , "300"
.程序集变量 _奖金项目3, 文本型, , "300"
.程序集变量 _奖金3, 文本型, , "300"
.程序集变量 _迟到, 文本型, , "300"
.程序集变量 _病假, 文本型, , "300"
.程序集变量 _事假, 文本型, , "300"
.程序集变量 _其它扣款, 文本型, , "300"
.程序集变量 _借款, 文本型, , "300"
.程序集变量 _个人社保, 文本型, , "300"
.程序集变量 _个人社保补缴, 文本型, , "300"
.程序集变量 _个人公积金, 文本型, , "300"
.程序集变量 _个人公积金补缴, 文本型, , "300"
.程序集变量 _个税, 文本型, , "300"
.程序集变量 _新秀实发, 文本型, , "300"
.程序集变量 _单位社保, 文本型, , "300"
.程序集变量 _单位社保补缴, 文本型, , "300"
.程序集变量 _单位公积金, 文本型, , "300"
.程序集变量 _单位公积金补缴, 文本型, , "300"
.程序集变量 _公司总支出, 文本型, , "300"
.程序集变量 _取邮箱地址, 文本型, , "300"

.子程序 _Send_被单击
.局部变量 _文本位置, 整数型
.局部变量 _html, 文本型, , "300"
.局部变量 值1, 文本型, , "300"
.局部变量 值2, 文本型, , "300"
.局部变量 值3, 文本型, , "300"
.局部变量 值4, 文本型, , "300"

.如果真 (编辑框行数.内容 = “”)
信息框 (“您未填写表格行数!”, 0, )
返回 ()
.如果真结束

.如果真 (年.内容 = “”)
信息框 (“您未填写年”, 0, )
返回 ()
.如果真结束
.如果真 (月.内容 = “”)
信息框 (“您未填写月”, 0, )
返回 ()
.如果真结束
Subject.内容 = 年.内容 + “年” + 月.内容 + “月工资单”
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_月份 [i] = 高级表格1.取数据 (i, 0)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_员工姓名 [i] = 高级表格1.取数据 (i, 1)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_工作天数 [i] = 高级表格1.取数据 (i, 2)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_月基本薪金 [i] = 高级表格1.取数据 (i, 3)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_备注 [i] = 高级表格1.取数据 (i, 4)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_午餐补贴 [i] = 高级表格1.取数据 (i, 5)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_全勤奖 [i] = 高级表格1.取数据 (i, 6)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_其它补贴 [i] = 高级表格1.取数据 (i, 7)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_奖金项目1 [i] = 高级表格1.取数据 (i, 8)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_奖金1 [i] = 高级表格1.取数据 (i, 9)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_奖金项目2 [i] = 高级表格1.取数据 (i, 10)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_奖金2 [i] = 高级表格1.取数据 (i, 11)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_奖金项目3 [i] = 高级表格1.取数据 (i, 12)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_奖金3 [i] = 高级表格1.取数据 (i, 13)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_迟到 [i] = 高级表格1.取数据 (i, 14)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_病假 [i] = 高级表格1.取数据 (i, 15)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_事假 [i] = 高级表格1.取数据 (i, 16)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_其它扣款 [i] = 高级表格1.取数据 (i, 17)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_借款 [i] = 高级表格1.取数据 (i, 18)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_个人社保 [i] = 高级表格1.取数据 (i, 19)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_个人社保补缴 [i] = 高级表格1.取数据 (i, 20)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_个人公积金 [i] = 高级表格1.取数据 (i, 21)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_个人公积金补缴 [i] = 高级表格1.取数据 (i, 22)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_个税 [i] = 高级表格1.取数据 (i, 23)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_新秀实发 [i] = 高级表格1.取数据 (i, 24)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_单位社保 [i] = 高级表格1.取数据 (i, 25)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_单位社保补缴 [i] = 高级表格1.取数据 (i, 26)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_单位公积金 [i] = 高级表格1.取数据 (i, 27)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_单位公积金补缴 [i] = 高级表格1.取数据 (i, 28)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()
i = 0
.判断循环首 (i < 高级表格1.行数)
i = i + 1
_公司总支出 [i] = 高级表格1.取数据 (i, 29)
.如果真 (i > 高级表格1.行数 - 2)
跳出循环 ()
.如果真结束

.判断循环尾 ()

i = 0
.判断循环首 (i < 高级表格1.行数 - 2)
i = i + 1
_取邮箱地址 [i] = 高级表格1.取数据 (i, 30)
.判断循环尾 ()

i = 0
值2 [300] = HtmlBody.内容
.判断循环首 (i < 高级表格1.行数 - 2)
i = i + 1
_文本位置 = 0
_文本位置 = 寻找文本 (HtmlBody.内容, “月份啊”, , 假)
_html [i] = 文本替换 (值2 [300], _文本位置, 取文本长度 (“月份啊”), _月份 [i])
值3 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值3 [i], “员工姓名啊”, , 假)
_html [i] = 文本替换 (值3 [i], _文本位置, 取文本长度 (“员工姓名啊”), _员工姓名 [i])
值4 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值4 [i], “工作天数啊”, , 假)
_html [i] = 文本替换 (值4 [i], _文本位置, 取文本长度 (“工作天数啊”), _工作天数 [i])
值3 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值3 [i], “月基本薪金啊”, , 假)
_html [i] = 文本替换 (值3 [i], _文本位置, 取文本长度 (“月基本薪金啊”), _月基本薪金 [i])
值4 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值4 [i], “备注啊”, , 假)
_html [i] = 文本替换 (值4 [i], _文本位置, 取文本长度 (“备注啊”), _备注 [i])
值3 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值3 [i], “午餐补贴啊”, , 假)
_html [i] = 文本替换 (值3 [i], _文本位置, 取文本长度 (“午餐补贴啊”), _午餐补贴 [i])
值4 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值4 [i], “全勤奖啊”, , 假)
_html [i] = 文本替换 (值4 [i], _文本位置, 取文本长度 (“全勤奖啊”), _全勤奖 [i])
值3 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值3 [i], “其它补贴啊”, , 假)
_html [i] = 文本替换 (值3 [i], _文本位置, 取文本长度 (“其它补贴啊”), _其它补贴 [i])
值4 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值4 [i], “奖金项目1啊”, , 假)
_html [i] = 文本替换 (值4 [i], _文本位置, 取文本长度 (“奖金项目1啊”), _奖金项目1 [i])
值3 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值3 [i], “奖金1啊”, , 假)
_html [i] = 文本替换 (值3 [i], _文本位置, 取文本长度 (“奖金1啊”), _奖金1 [i])
值4 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值4 [i], “奖金项目2啊”, , 假)
_html [i] = 文本替换 (值4 [i], _文本位置, 取文本长度 (“奖金项目2啊”), _奖金项目2 [i])
值3 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值3 [i], “奖金2啊”, , 假)
_html [i] = 文本替换 (值3 [i], _文本位置, 取文本长度 (“奖金2啊”), _奖金2 [i])
值4 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值4 [i], “奖金项目3啊”, , 假)
_html [i] = 文本替换 (值4 [i], _文本位置, 取文本长度 (“奖金项目3啊”), _奖金项目3 [i])
值3 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值3 [i], “奖金3啊”, , 假)
_html [i] = 文本替换 (值3 [i], _文本位置, 取文本长度 (“奖金3啊”), _奖金3 [i])
值4 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值4 [i], “迟到啊”, , 假)
_html [i] = 文本替换 (值4 [i], _文本位置, 取文本长度 (“迟到啊”), _迟到 [i])
值3 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值3 [i], “病假啊”, , 假)
_html [i] = 文本替换 (值3 [i], _文本位置, 取文本长度 (“病假啊”), _病假 [i])
值4 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值4 [i], “事假啊”, , 假)
_html [i] = 文本替换 (值4 [i], _文本位置, 取文本长度 (“事假啊”), _事假 [i])
值3 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值3 [i], “其它扣款啊”, , 假)
_html [i] = 文本替换 (值3 [i], _文本位置, 取文本长度 (“其它扣款啊”), _其它扣款 [i])
值4 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值4 [i], “借款啊”, , 假)
_html [i] = 文本替换 (值4 [i], _文本位置, 取文本长度 (“借款啊”), _借款 [i])
值3 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值3 [i], “个人社保啊”, , 假)
_html [i] = 文本替换 (值3 [i], _文本位置, 取文本长度 (“个人社保啊”), _个人社保 [i])
值4 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值4 [i], “个人社保补缴啊”, , 假)
_html [i] = 文本替换 (值4 [i], _文本位置, 取文本长度 (“个人社保补缴啊”), _个人社保补缴 [i])
值3 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值3 [i], “个人公积金啊”, , 假)
_html [i] = 文本替换 (值3 [i], _文本位置, 取文本长度 (“个人公积金啊”), _个人公积金 [i])
值4 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值4 [i], “个人公积金补缴啊”, , 假)
_html [i] = 文本替换 (值4 [i], _文本位置, 取文本长度 (“个人公积金补缴啊”), _个人公积金补缴 [i])
值3 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值3 [i], “个税啊”, , 假)
_html [i] = 文本替换 (值3 [i], _文本位置, 取文本长度 (“个税啊”), _个税 [i])
值4 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值4 [i], “新秀实发啊”, , 假)
_html [i] = 文本替换 (值4 [i], _文本位置, 取文本长度 (“新秀实发啊”), _新秀实发 [i])
值3 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值3 [i], “单位社保啊”, , 假)
_html [i] = 文本替换 (值3 [i], _文本位置, 取文本长度 (“单位社保啊”), _单位社保 [i])
值4 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值4 [i], “单位社保补缴啊”, , 假)
_html [i] = 文本替换 (值4 [i], _文本位置, 取文本长度 (“单位社保补缴啊”), _单位社保补缴 [i])
值3 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值3 [i], “单位公积金啊”, , 假)
_html [i] = 文本替换 (值3 [i], _文本位置, 取文本长度 (“单位公积金啊”), _单位公积金 [i])
值4 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值4 [i], “单位公积金补缴啊”, , 假)
_html [i] = 文本替换 (值4 [i], _文本位置, 取文本长度 (“单位公积金补缴啊”), _单位公积金补缴 [i])
值3 [i] = _html [i]

_文本位置 = 0
_文本位置 = 寻找文本 (值3 [i], “公司总支出啊”, , 假)
_html [i] = 文本替换 (值3 [i], _文本位置, 取文本长度 (“公司总支出啊”), _公司总支出 [i])
值4 [i] = _html [i]

.判断循环尾 ()

i = 0
.判断循环首 (i < 高级表格1.行数 - 2)
i = i + 1
SendMail (_取邮箱地址 [i], BCC.内容, CC.内容, From.内容, FromName.内容, ReplyTo.内容, Subject.内容, TextBody.内容, 值4 [i], Attachments.内容, EncodingCharset.内容, Mime.选中, Priority.现行选中项, XMailer.内容, DSN.选中, DSNSuccess.选中, DSNFailure.选中, DSNDelay.选中, DSNHeaders.选中, MDN.选中, SmtpHost.内容, UserName.内容, Password.内容, 到整数 (SmtpPort.内容), Authentication.现行选中项, ConnectionType.现行选中项, DNSLookup.选中, 到整数 (Timeout.内容), AutoDial.选中, BoundIP.内容)
.判断循环尾 ()

.子程序 __启动窗口_创建完毕
.局部变量 _文本位置, 整数型

高级表格1.置数据 (0, 0, #表格常量.文本型, “月份”)
高级表格1.置数据 (0, 1, #表格常量.文本型, “员工姓名”)
高级表格1.置数据 (0, 2, #表格常量.文本型, “工作天数”)
高级表格1.置数据 (0, 3, #表格常量.文本型, “月基本薪金”)
高级表格1.置数据 (0, 4, #表格常量.文本型, “备注”)
高级表格1.置数据 (0, 5, #表格常量.文本型, “午餐补贴”)
高级表格1.置数据 (0, 6, #表格常量.文本型, “全勤奖”)
高级表格1.置数据 (0, 7, #表格常量.文本型, “其它补贴”)
高级表格1.置数据 (0, 8, #表格常量.文本型, “奖金项目1”)
高级表格1.置数据 (0, 9, #表格常量.文本型, “奖金1”)
高级表格1.置数据 (0, 10, #表格常量.文本型, “奖金项目2”)
高级表格1.置数据 (0, 11, #表格常量.文本型, “奖金2”)
高级表格1.置数据 (0, 12, #表格常量.文本型, “奖金项目3”)
高级表格1.置数据 (0, 13, #表格常量.文本型, “奖金3”)
高级表格1.置数据 (0, 14, #表格常量.文本型, “迟到”)
高级表格1.置数据 (0, 15, #表格常量.文本型, “病假”)
高级表格1.置数据 (0, 16, #表格常量.文本型, “事假”)
高级表格1.置数据 (0, 17, #表格常量.文本型, “其它扣款”)
高级表格1.置数据 (0, 18, #表格常量.文本型, “借款”)
高级表格1.置数据 (0, 19, #表格常量.文本型, “个人社保”)
高级表格1.置数据 (0, 20, #表格常量.文本型, “个人社保补缴”)
高级表格1.置数据 (0, 21, #表格常量.文本型, “个人公积金”)
高级表格1.置数据 (0, 22, #表格常量.文本型, “个人公积金补缴”)
高级表格1.置数据 (0, 23, #表格常量.文本型, “个税”)
高级表格1.置数据 (0, 24, #表格常量.文本型, “新秀实发”)
高级表格1.置数据 (0, 25, #表格常量.文本型, “单位社保”)
高级表格1.置数据 (0, 26, #表格常量.文本型, “单位社保补缴”)
高级表格1.置数据 (0, 27, #表格常量.文本型, “单位公积金”)
高级表格1.置数据 (0, 28, #表格常量.文本型, “单位公积金补缴”)
高级表格1.置数据 (0, 29, #表格常量.文本型, “公司总支出”)
高级表格1.置数据 (0, 30, #表格常量.文本型, “邮箱地址”)
_空格 = “ ”

.子程序 _设置表格_被单击

高级表格1.行数 = 到整数 (编辑框行数.内容) + 2

-------------------------------------------自定义DLL----------------------------------------------------
.版本 2

.DLL命令 SendMail, , "SSLMail.dll", "SendMail2"
.参数 收件人, 文本型, , 用英文逗号或英文分号分隔
.参数 暗送, 文本型, , 用英文逗号或英文分号分隔
.参数 抄送, 文本型, , 用英文逗号或英文分号分隔
.参数 寄件人, 文本型
.参数 寄件人姓名, 文本型
.参数 回复地址, 文本型
.参数 标题, 文本型
.参数 纯文本正文, 文本型
.参数 html正文, 文本型
.参数 附件, 文本型, , 用英文逗号或英文分号分隔
.参数 字符编码, 文本型
.参数 mime编码, 逻辑型
.参数 优先级, 整数型
.参数 XMailer, 文本型
.参数 DSN, 逻辑型
.参数 DSNSuccess, 逻辑型
.参数 DSNFailure, 逻辑型
.参数 DSNDelay, 逻辑型
.参数 DSNHeaders, 逻辑型
.参数 MDN, 逻辑型
.参数 smtpHost, 文本型
.参数 用户名, 文本型
.参数 密码, 文本型
.参数 端口, 整数型
.参数 身份验证方式, 整数型
.参数 连接方式, 整数型
.参数 DNSLoopkup, 逻辑型
.参数 超时, 整数型
.参数 自动拨号, 逻辑型

.参数 绑定IP, 文本型